Classic-Castle.com


The source for all your LEGO Castle needs!

I have returned...

General USER announcements, such as introductions and away messages.

I have returned...

Postby BrianofBrick06 » Thu Oct 01, 2009 9:46 pm

Hello again classic-castle! It has been a few months since i've been here last, and that is certainly too long to go without my lego community fix. It has definitely been a long few months (due to a past i have been trying to escape that had temporarily resurfaced), but I am back and all is now well. I look forward to continuing as a member here. Hello to everyone who has joined the site during my absence... :wave:
User avatar
BrianofBrick06
Apprentice
 
Posts: 195
Joined: Sat Jan 31, 2009 1:04 am
Location: Pa

Re: I have returned...

Postby g2 » Fri Oct 02, 2009 3:30 am

Welcome back to the forums. I am not sure if I should really be saying this to you, as I too have been away from this lovely forum.
User avatar
g2
Sir Postsalot
 
Posts: 1053
Joined: Thu Feb 17, 2005 10:20 pm
Location: Melbourne, Australia - Age 38

Re: I have returned...

Postby Quickblade22 » Fri Oct 02, 2009 8:10 am

It's great to see both of you back. An old friend and a newer friend....so :woo: for reappearances. BTW g2, I PMed ya on Jan13th, and it says you never got it :tasty:
Chief Smithy of Brick Forge
I buy LEGO, I play with LEGO, therefore LEGO are not for children, they are for me!
User avatar
Quickblade22
22 times da man
 
Posts: 996
Joined: Wed Sep 15, 2004 2:04 am
Location: Classic-Castle.....err New Castle, PA

Re: I have returned...

Postby JoshWedin » Thu Oct 22, 2009 2:50 pm

Welcome back, Brian. Good to see you again!

Josh
AFOL and his money are easily parted.

Image The Brothers Brick
User avatar
JoshWedin
Chevalier de Chèvre
Chevalier de Chèvre
 
Posts: 5642
Joined: Sun Nov 09, 2003 2:35 pm
Location: Pondering what you are pondering


Return to Announcements

Who is online

Users browsing this forum: verneer and 1 guest